• Advertisement

Archived

This topic is now archived and is closed to further replies.

Do u have a Voodoo3?

This topic is 6053 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

If you do could u pls download and test my D3D game on your system, I need to make sure it works correctly since im using 512x512 textures and colorkeying. Please post your Voodoo3 specs and framerate (Press ''F''), thanks

  Downloads:  ZeroOne Realm

Share this post


Link to post
Share on other sites
Advertisement
I have a voodoo3 3000, it''s not hooked up though, it was taking to much resources to have my geforce2mx and voodoo3 both hooked up for dual monitors, so I had to cut back...
If you don''t get a reply soon, I''m going to be hooking it up again either tonight, or tommorow, (gotta play FF7...) and I''ll check it out for you.

If that doesn''t sound good, well, you just got a bump up the list!



Drakonite

[Insert Witty Signature Here]

Share this post


Link to post
Share on other sites
Hey,
I have Voodoo3 2000.

Nice game!

I''ve been programming 3d wrapper for d3d and ogl, and I know that my card supports max 256 size textures.

I tried with different BPPs. First when I run the game, it shows black screen with some blue color in the middle and it''s written P E EN E down the screen. I think there should read PRESS ENTER?
Seems that screenshots are not working out. I think that it shoud show some shots (?) but I can''t see any pictures. I also see mouse cursor in fullscreen, but cannot move it.

Then comes the loading section and the load progress bar seems to work well and then game seem to run ok! Didn''t notice any weird in game mode.

FPS was min 12 to max 34.

If you need some more info or tests, let me know!

You could also try out my net racing demo that runs on my gfx/net wrapper: www.geocities.com/stefankjb/download

Share this post


Link to post
Share on other sites
I use a Voodoo 3 3000 AGP at home. I run it in an AMD T-Bird 900 with 128MB of ram on Windows Me. I''ll give it a shot when I get home and let you know how it works.

- Mike

Share this post


Link to post
Share on other sites
I forgot to post what happened when I put in my voodoo3... Well, it didn''t work. It locked up right away, and caused my entire system to lock up.
It may have something to do with the dual video cards, as many software doesn''t like to video cards, but I don''t know.

Sorry I couldn''t be more of help.



Drakonite

[Insert Witty Signature Here]

Share this post


Link to post
Share on other sites
Thanks everyone for testing my game

Stefu:
Its strange how the level area works fine - it has 512x512 textures!

I''m not exactly sure why the title screen went hay-wire, I''m guessing its because some of the title textures are not square, some of them are 512x64.
The P E EN E problem is probably because the S, T and R letters are passed 256 pixels. Ill resize my bitmaps and upload a new version within a few days so you can quickly test it again.

Sorry Darkonite for locking up your system, I have no idea why it happened. If you still have the Debug-output file outputted by ZeroOne when it crashed could you please send it to me so I can work out what happened, thanks. NSZeroOne@Hotmail.com

  Downloads:  ZeroOne Realm

Share this post


Link to post
Share on other sites
By the way, my Voodoo3 2000 is PCI version.

I looked in the ZODbgOut.txt and there was thousands of D3DERR_INVALIDCALLs (about 29000!).
Other errors were "Failed Blit in CHAR_Blit" and "Failed Util Blit (nUtil 13) (UtilType 8) Alloc 1".

If you use D3DXCreateTextureFromFile(), it resizes textures to proper size.

Share this post


Link to post
Share on other sites
Sorry, but I don''t have the error file anymore
I would run it again to generate another one, but my voodoo3 had to be removed as after my computer has been on for a few hours, it started to build up too much heat.

However, i did run it on my 400mhz celeron w/ geforce2mx, and you may want to know that it ran very, well... hyper. It may be that it usually slows it self down by capping the frame rate using v-sync, and that v-sync is disabled.

Sorry I couldn''t be of more help with the voodoo.



Drakonite

[Insert Witty Signature Here]

Share this post


Link to post
Share on other sites
I ain''t using a V3 for starters but if you want to add another supportable card to your readme list the GeForce2 Pro. Alls well, high framerates (lowest ~36fps in the loading scene), 96-120fps most of the game, gets around low 80''s/high 70''s occasionally when lots of stuff happening in screen.

Is it possible to achieve a victory in the game at this point or not?

-epsilon

Share this post


Link to post
Share on other sites
I got 12 to 22 fps most of the time although I managed to get as low as 6 fps.

Problems:

1) The "press enter" text is FUBAR''ed.

2) The game *seems* to crash at first, repeating the same four or five seconds of music over and over. For about 40 seconds I am unable to do anything. Nothing happens when I press ALT+TAB or CTRL+ALT+DEL. After those fourty seconds the screen changes colour a couple of times and after a total of more than 60 seconds a progress bar appears.

3) Some parts of the invisible platforms are visible, probably due to the vast power consumption of platform cloaking devices. Then again, maybe the platforms actually were meant to be visible and some evil bug ate some of the code in your platform drawing routine, causing some parts of the platform not to be drawn.

4) Water is transparent. In fact, water is very transparent. But I''ve never seen any water quite as transparent as the water in your game

My configuration:

AMD K6-2 450mhz
64 MB PC100 RAM
Voodoo 3 3000 with latest drivers
Windows 98 SE
DirectX 8a

BTW: It is possible to move the cursor, but it''s only updated once every 5 or 10 seconds.

Good luck killing those bugs. Make them suffer

Share this post


Link to post
Share on other sites
Thanks everyone for testing the game, I have recently updated the game so its more Voodoo3 compatible, well basically what I've done is resized the textures that were causing problems to 256x256 so the title screen *should* work 100% now. The main game area still has 512x512 backgrounds but this is a minor issue and shouldnt affect the foreground gameplay.

Thanks Epsilion for testing it on a GeForce2, ive added it to the readme.txt file.

[qoute]
2) The game *seems* to crash at first, repeating the same four or five seconds of music over and over. For about 40 seconds I am unable to do anything. Nothing happens when I press ALT+TAB or CTRL+ALT+DEL. After those fourty seconds the screen changes colour a couple of times and after a total of more than 60 seconds a progress bar appears.


...This is probably because DX is resizing the 512x512 textures to 256x256 which can be very slow for some reason. This prob is hopefully fixed now.


If u have a Voodoo3 could u pls download the new version (0.7I) and test so I can make sure its working fine...thanks in advance

  Downloads:  ZeroOne Realm





Edited by - SikCiv on July 30, 2001 2:04:14 AM

Share this post


Link to post
Share on other sites
I have a voodoo 3 3000 agp, and your game ran fine-except that some of the floors wern''t drawn. You could walk on them but they weren''t visible. Also I pressed esc twice to exit the game and it returned to the desktop at 640x480 res, got an error (one of those this program has caused an error boxes), and the mouse was frozen dead center on the screen, had to reboot... but it was fun!

BTW sound was off, 32 bit color also, everything set to max.

My ddraw programs sometimes did the exact same thing-I think it was because I didn''t unregister something-if I remember I''ll post it.

Share this post


Link to post
Share on other sites
It worked now!

But also for me some of the floors didn''t draw. I added a shot here to see how it looks: www.geocities.com/stefankjb/ZOShot.jpg

But, why does the dbg file has about 30000 lines of D3DERR_INVALID CALL and other errors???

Otherwise everything looked ok.

Share this post


Link to post
Share on other sites
Thanks guys for testing it

Stefu,
Thanks for the screen shot, I''m pretty sure the D3DERR_INVALID_CALL''s are because of the 512x512 textures, the textures are resized to 256x256 (including the floors texture which is why some dont blit) but when I blit using a srcRect above 256 the blit fails resulting in the D3D error.
I guess I need to cut the 512x512 textures into fours so the construction blits ok.

gph-gw,
Sounds like u are using old voodoo3 drivers or a mixture of different DX versions, u should try installing the latest drivers and re-installing DX8 to fix your problem.

If only the voodoo3 could handle 512x512 It would save alot of hassle..

  Downloads:  ZeroOne Realm

Share this post


Link to post
Share on other sites

  • Advertisement