Jump to content
  • Advertisement
Sign in to follow this  
altra4u

OpenGL Focus lost(processing halts stops) when hover inside/out window boundaries

This topic is 3345 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi guys, I have this weird problem and I don't understand what exactly is going on.I feel like it might have to do with how you set up openGL. So I create a window and I set the display and idle functions. I have cout statements in both of them printing display and idle respectively. Now when I rollout of the window(without having any pressed any mouse button.so i'm not dragging.i'm just going out the window) and roll-in and keep on doing this back and forth, many a times after rolling out of the window the processing stops. It stops printing the display,idle messages too. Its exactly the same as what happens when you are dragging around the opengl window. The moment I roll into the window or click on visual studio 2005 window it starts processing again. Can someone explain this behavior and how to solve it? Thanks. Chit

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!