Jump to content
  • Advertisement
Sign in to follow this  
troxtril

texturing problem

This topic is 3257 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hey, when I bind a texture on 2 different quads with different texcoords (second one starts where first one ends) the last line of pixels of the first quad is blended with some darker color. why would this happen? my texture filters are:

glTexParameteri(GL_TEXTURE_2D, GL_GENERATE_MIPMAP, GL_TRUE);
glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_MIN_FILTER, GL_LINEAR_MIPMAP_NEAREST);
glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_MAG_FILTER, GL_LINEAR);




I tried GL_CLAMP, GL_REPEAT, GL_CLAMP_TO_EDGE parameters and different filter modes, only GL_NEAREST for both min and mag filters with no mipmap levels solved the problem with an unacceptable cost of distortion on the texture. help please?

Share this post


Link to post
Share on other sites
Advertisement
problem is the last line of pixels of a textured quad blends with something (background maybe?) I believe this is about orthographic projection. when I move the quad, the blending ratio changes. for some y values this is nearly 0 and as I move along y axis it goes to 1 and this line becomes nearly invisible. how can I solve this? I believe this is a side effect of ortho?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!