Archived

This topic is now archived and is closed to further replies.

Blade Runner

Just A Simiple Error Question.

Recommended Posts

I know this is a funny question to ask but I''ll ask it anyway. I just made a debugger for my demo and I was curious about how and why do the following ERRORS occur, becasue I wanted to make sure that debugger worked in everyway possible. Failed To Register The Window Class. Failed To Register The Window Class. Can''t Create A GL Device Context. Can''t Find A Suitable PixelFormat. Can''t Set The PixelFormat. Can''t Create A GL Rendering Context. Can''t Activate The GL Rendering Context.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Yeah my card is OpenGL compatible, I just wanted to know how and why those errors occured, becasue I wanted to make sure that debugger caught every error that occured in the program.

The question you asked leads me to think that those errors only occur if your card is not OpenGL compatible, am I correct? I know the Can''t Activate The GL Rendering Context error happens when your program does not start or close correctly, and then you go to run a OpenGL program later and that message occurs.

Share this post


Link to post
Share on other sites
Yeah my card is OpenGL compatible, I just wanted to know how and why those errors occured, becasue I wanted to make sure that debugger caught every error that occured in the program.

The question you asked leads me to think that those errors only occur if your card is not OpenGL compatible, am I correct? I know the Can''t Activate The GL Rendering Context error happens when your program does not start or close correctly, and then you go to run a OpenGL program later and that message occurs.

Share this post


Link to post
Share on other sites

Without seeing some actual code I can''t say for sure what''s causing the problems but here''s my best guess''s...
quote:
Original post by Blade Runner
Failed To Register The Window Class.
Failed To Register The Window Class.


The window class was not registered correctly in the function RegisterWindowClass. This probably caused the window to never be created. Check to see if you might have that message for the CreateWindow debug message too as that function call will fail without a properly registered window class
quote:
Original post by Blade Runner
Can''t Create A GL Device Context.


This is probably the call to GetDC not having a valid window.
quote:
Original post by Blade Runner
Can''t Find A Suitable PixelFormat.


This is the call to ChoosePixelFormat not haveing a valid device context
quote:
Original post by Blade Runner
Can''t Set The PixelFormat.


This is not haveing a valid pixel format returned from the ChoosePixelFormat function
quote:
Original post by Blade Runner
Can''t Create A GL Rendering Context.


Again no valid device context
quote:
Original post by Blade Runner
Can''t Activate The GL Rendering Context.


No GL rendering context to activate.

To summarize...
Your program is not able to register the window class for some reason then everything after that is failing due to the fact that it requires that all the previous code have worked to provide proper values.
But as I said, without seeing the code I can''t say for sure...

Share this post


Link to post
Share on other sites