Jump to content
  • Advertisement
Sign in to follow this  
lephyrius

Xcode/gcc errors

This topic is 3213 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am trying to see what error this is: /Developer/SDKs/MacOSX10.6.sdk/usr/include/i386/_types.h:37:0 /Developer/SDKs/MacOSX10.6.sdk/usr/include/i386/_types.h:37: error: expected constructor, destructor, or type conversion before 'typedef' /Guidance.h:13:0 In file included from /Guidance.h /Developer/SDKs/MacOSX10.6.sdk/usr/include/c++/4.2.1/string:45:0 In file included from /Developer/SDKs/MacOSX10.6.sdk/usr/include/c++/4.2.1/string /Developer/SDKs/MacOSX10.6.sdk/usr/include/c++/4.2.1/i686-apple-darwin10/bits/c++config.h:41:0 In file included from /Developer/SDKs/MacOSX10.6.sdk/usr/include/c++/4.2.1/i686-apple-darwin10/bits/c++config.h /Developer/SDKs/MacOSX10.6.sdk/usr/include/c++/4.2.1/i686-apple-darwin10/bits/os_defines.h:61:0 In file included from /Developer/SDKs/MacOSX10.6.sdk/usr/include/c++/4.2.1/i686-apple-darwin10/bits/os_defines.h /Developer/SDKs/MacOSX10.6.sdk/usr/include/unistd.h:71:0 In file included from /Developer/SDKs/MacOSX10.6.sdk/usr/include/unistd.h /Developer/SDKs/MacOSX10.6.sdk/usr/include/_types.h:27:0 In file included from /Developer/SDKs/MacOSX10.6.sdk/usr/include/_types.h /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/_types.h:33:0 In file included from /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/_types.h /Developer/SDKs/MacOSX10.6.sdk/usr/include/machine/_types.h:34:0 In file included from /Developer/SDKs/MacOSX10.6.sdk/usr/include/machine/_types.h /Developer/SDKs/MacOSX10.6.sdk/usr/include/i386/_types.h:37:0 Expected constructor, destructor, or type conversion before 'typedef' in /Developer/SDKs/MacOSX10.6.sdk/usr/include/i386/_types.h I tried to write a test case but the error didn't appear in it: I am using: Xcode 3.2 / Snow Leopard / SDL 1.2.14 / Boost 1.40 Any idea where to start looking? I tried to reorder the include files but it didn't help or it created another error.

Share this post


Link to post
Share on other sites
Advertisement
Make sure that both boost and SDL have been compiled for 64-bit (snow leopard defaults to 64-bit). You can use terminal to run lipo -info filename on each library to check for 64-bit support.

Share this post


Link to post
Share on other sites
Quote:
Original post by lephyrius
I tried to write a test case but the error didn't appear in it:
I am using:
Xcode 3.2 / Snow Leopard / SDL 1.2.14 / Boost 1.40

Try again. Rather than starting from scratch, exclude code with comments/"#if 0" until it compiles.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!