Sign in to follow this  
rxa

OpenGL Setting up GLSL vertex and fragment shaders

Recommended Posts

rxa    149
Hi! I just tried to setup glsl but ran in some problems with it. Or running my vertex shader is actually the problem. It seems that fragment shader works but vertex shader is complitely skipped. I draw my object like this:

shader_enable();

  GLUquadric* sphere = gluNewQuadric();

  glColor3f( 0.6f, 0.2f, 0.2f );
  gluSphere(sphere, 2.f, 12, 12);

shader_disable();
vs:
varying float diffuse_value; // using this in fs

void main() {			
	
	diffuse_value = 1.0; // assign it to 1.0 so that theres no color change
	
	gl_FrontColor = gl_Color; 
	gl_Position = gl_ModelViewProjectionMatrix * gl_Vertex;
}
fs:
varying float diffuse_value;

void main() {
        // diffuse value should be 1.0 now, but I get complitely black object.
	gl_FragColor = gl_Color * diffuse_value; 
}
So I should be able to adjust the color via diffuse_value variable, but it has no effect, no matter what I assign it to.. it get as zero to fragment shader. heres my shader init code:
#include "glew.h"
#include "gl.h"
#include "glu.h"
	
void shader_init(){

	glewInit( );
	if( GLEW_ARB_vertex_shader && GLEW_ARB_fragment_shader )
		std::cout << "GLSL OK!" << std::endl;
	else{
		std::cout << "GLSL NOT OK.." << std::endl;
                return;
        }
        const char * vsText = readFile( "myshader.vert" );
	const char * fsText = readFile( "myshader.frag" );
	
	shader_vs = glCreateShaderObjectARB( GL_VERTEX_SHADER_ARB );
	shader_fs = glCreateShaderObjectARB( GL_FRAGMENT_SHADER_ARB );

	glShaderSourceARB( shader_vs, 1, &vsText, NULL );
	glShaderSourceARB( shader_fs, 1, &fsText, NULL );

	glCompileShaderARB( shader_vs );
	glCompileShaderARB( shader_fs );

	shader_p = glCreateProgramObjectARB( );

	glAttachObjectARB( shader_p, shader_vs );
	glAttachObjectARB( shader_p, shader_fs );

	glLinkProgramARB( shader_p );
	glUseProgramObjectARB( shader_p );
}
I also checked with debugger that shader files are readed in alright. Any Idea what might cause this? What libs do you use, you prefer using shaders with glut? Because the only difference I find between my project and tutorial projects is that they use glut and I dont.. I'm following these tutorials: http://www.lighthouse3d.com/opengl/glsl/index.php?oglexample1 http://www.swiftless.com/tutorials/glsl/1_setup/1_setup.html#DL NOTE: Few days ago I tried cg shader and it worked ok, so my gfx-card should be ok. Theres just something I am missing here. thanks Patrick

Share this post


Link to post
Share on other sites
lightbringer    1070
I don't see anything obviously wrong with it, though I only have basic familiarity with GLSL. Have you tried reading back the info log from the compiler?


Pseudocode:

glGetShader(shaderID, GL_COMPILE_STATUS, error); // tells you if there is an error

glGetShader(shaderID, GL_INFO_LOG_LENGTH, length); // length of log, needed for reading it back
glGetShaderInfoLog(shaderID, length, infoLog); // read back info log



Also glGetProgram() and glGetProgramInfoLog() do the same for the program itself, so do that one also.

Share this post


Link to post
Share on other sites
rxa    149
Thanks lightbringer,

I tried using glGetShader, and glGetProgram. I checked for compile status and it was ok for both. I also made by purpose a small error in vertex shader program to check that I get the error from glGetShader and yes, I got it. So at least it is compiled. I just do not understand why the vertex shader seems to be complitely ignored..

Share this post


Link to post
Share on other sites
rxa    149
I tried drawing different kinds of objects, single triangles, quads, everything, but no help..

But, I actually got it working.. don't know why but I use this code snippet instead and it worked out good:

static void setShaders(){
GLuint p,s;
p = ((PFNGLCREATEPROGRAMPROC)wglGetProcAddress("glCreateProgram"))();
s = ((PFNGLCREATESHADERPROC)(wglGetProcAddress("glCreateShader")))(GL_VERTEX_SHADER);
((PFNGLSHADERSOURCEPROC)wglGetProcAddress("glShaderSource")) (s, 1, &vsh, NULL);
((PFNGLCOMPILESHADERPROC)wglGetProcAddress("glCompileShader"))(s);
((PFNGLATTACHSHADERPROC)wglGetProcAddress("glAttachShader")) (p,s);

s = ((PFNGLCREATESHADERPROC)wglGetProcAddress("glCreateShader"))(GL_FRAGMENT_SHADER);
((PFNGLSHADERSOURCEPROC)wglGetProcAddress("glShaderSource")) (s, 1, &fsh, NULL);
((PFNGLCOMPILESHADERPROC)wglGetProcAddress("glCompileShader"))(s);
((PFNGLATTACHSHADERPROC)wglGetProcAddress("glAttachShader")) (p,s);

((PFNGLLINKPROGRAMPROC)wglGetProcAddress("glLinkProgram"))(p);
((PFNGLUSEPROGRAMPROC) wglGetProcAddress("glUseProgram"))(p);
}


Its the same code but packed in a small size, I copied it from here for testing purposes:
http://sizecoding.blogspot.com/2007/10/tiny-code-to-setup-glsl-shaders.html

In this solution I am not using glew at all, I am doing the nasty setuping myself, using only the functions I need.
It seems that glew does(or doesnt do) something it should. Maybe it really needs glut to cooperate with? But I'd rather not use glut since it's horribly outdated nowadays.

Using GL extensions(new functionality) properly isn't the most well documented area, if anyone has suggestions for good sources of information for the topic in question, please tell. (Books, tutorial pages, everything appreciated).

thanks

p

Share this post


Link to post
Share on other sites
lightbringer    1070
I've never had to use GLUT or anything, but then LWJGL spoils me with wrapper classes like GL11, GL20, GL30... not like you C++ on Windows guys who have to struggle with having only 1.1 headers. :D to be honest I find what happened in your case pretty weird, but hey, if it works now, no need to fix it (for now). You'll be rewriting those shaders soon enough anyway, if you plan to support GLSL 1.5.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • By Kjell Andersson
      I'm trying to get some legacy OpenGL code to run with a shader pipeline,
      The legacy code uses glVertexPointer(), glColorPointer(), glNormalPointer() and glTexCoordPointer() to supply the vertex information.
      I know that it should be using setVertexAttribPointer() etc to clearly define the layout but that is not an option right now since the legacy code can't be modified to that extent.
      I've got a version 330 vertex shader to somewhat work:
      #version 330 uniform mat4 osg_ModelViewProjectionMatrix; uniform mat4 osg_ModelViewMatrix; layout(location = 0) in vec4 Vertex; layout(location = 2) in vec4 Normal; // Velocity layout(location = 3) in vec3 TexCoord; // TODO: is this the right layout location? out VertexData { vec4 color; vec3 velocity; float size; } VertexOut; void main(void) { vec4 p0 = Vertex; vec4 p1 = Vertex + vec4(Normal.x, Normal.y, Normal.z, 0.0f); vec3 velocity = (osg_ModelViewProjectionMatrix * p1 - osg_ModelViewProjectionMatrix * p0).xyz; VertexOut.velocity = velocity; VertexOut.size = TexCoord.y; gl_Position = osg_ModelViewMatrix * Vertex; } What works is the Vertex and Normal information that the legacy C++ OpenGL code seem to provide in layout location 0 and 2. This is fine.
      What I'm not getting to work is the TexCoord information that is supplied by a glTexCoordPointer() call in C++.
      Question:
      What layout location is the old standard pipeline using for glTexCoordPointer()? Or is this undefined?
       
      Side note: I'm trying to get an OpenSceneGraph 3.4.0 particle system to use custom vertex, geometry and fragment shaders for rendering the particles.
    • By markshaw001
      Hi i am new to this forum  i wanted to ask for help from all of you i want to generate real time terrain using a 32 bit heightmap i am good at c++ and have started learning Opengl as i am very interested in making landscapes in opengl i have looked around the internet for help about this topic but i am not getting the hang of the concepts and what they are doing can some here suggests me some good resources for making terrain engine please for example like tutorials,books etc so that i can understand the whole concept of terrain generation.
       
    • By KarimIO
      Hey guys. I'm trying to get my application to work on my Nvidia GTX 970 desktop. It currently works on my Intel HD 3000 laptop, but on the desktop, every bind textures specifically from framebuffers, I get half a second of lag. This is done 4 times as I have three RGBA textures and one depth 32F buffer. I tried to use debugging software for the first time - RenderDoc only shows SwapBuffers() and no OGL calls, while Nvidia Nsight crashes upon execution, so neither are helpful. Without binding it runs regularly. This does not happen with non-framebuffer binds.
      GLFramebuffer::GLFramebuffer(FramebufferCreateInfo createInfo) { glGenFramebuffers(1, &fbo); glBindFramebuffer(GL_FRAMEBUFFER, fbo); textures = new GLuint[createInfo.numColorTargets]; glGenTextures(createInfo.numColorTargets, textures); GLenum *DrawBuffers = new GLenum[createInfo.numColorTargets]; for (uint32_t i = 0; i < createInfo.numColorTargets; i++) { glBindTexture(GL_TEXTURE_2D, textures[i]); GLint internalFormat; GLenum format; TranslateFormats(createInfo.colorFormats[i], format, internalFormat); // returns GL_RGBA and GL_RGBA glTexImage2D(GL_TEXTURE_2D, 0, internalFormat, createInfo.width, createInfo.height, 0, format, GL_FLOAT, 0); glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_MAG_FILTER, GL_NEAREST); glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_MIN_FILTER, GL_NEAREST); DrawBuffers[i] = GL_COLOR_ATTACHMENT0 + i; glBindTexture(GL_TEXTURE_2D, 0); glFramebufferTexture(GL_FRAMEBUFFER, GL_COLOR_ATTACHMENT0 + i, textures[i], 0); } if (createInfo.depthFormat != FORMAT_DEPTH_NONE) { GLenum depthFormat; switch (createInfo.depthFormat) { case FORMAT_DEPTH_16: depthFormat = GL_DEPTH_COMPONENT16; break; case FORMAT_DEPTH_24: depthFormat = GL_DEPTH_COMPONENT24; break; case FORMAT_DEPTH_32: depthFormat = GL_DEPTH_COMPONENT32; break; case FORMAT_DEPTH_24_STENCIL_8: depthFormat = GL_DEPTH24_STENCIL8; break; case FORMAT_DEPTH_32_STENCIL_8: depthFormat = GL_DEPTH32F_STENCIL8; break; } glGenTextures(1, &depthrenderbuffer); glBindTexture(GL_TEXTURE_2D, depthrenderbuffer); glTexImage2D(GL_TEXTURE_2D, 0, depthFormat, createInfo.width, createInfo.height, 0, GL_DEPTH_COMPONENT, GL_FLOAT, 0); glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_MAG_FILTER, GL_NEAREST); glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_MIN_FILTER, GL_NEAREST); glBindTexture(GL_TEXTURE_2D, 0); glFramebufferTexture(GL_FRAMEBUFFER, GL_DEPTH_ATTACHMENT, depthrenderbuffer, 0); } if (createInfo.numColorTargets > 0) glDrawBuffers(createInfo.numColorTargets, DrawBuffers); else glDrawBuffer(GL_NONE); if (glCheckFramebufferStatus(GL_FRAMEBUFFER) != GL_FRAMEBUFFER_COMPLETE) std::cout << "Framebuffer Incomplete\n"; glBindFramebuffer(GL_FRAMEBUFFER, 0); width = createInfo.width; height = createInfo.height; } // ... // FBO Creation FramebufferCreateInfo gbufferCI; gbufferCI.colorFormats = gbufferCFs.data(); gbufferCI.depthFormat = FORMAT_DEPTH_32; gbufferCI.numColorTargets = gbufferCFs.size(); gbufferCI.width = engine.settings.resolutionX; gbufferCI.height = engine.settings.resolutionY; gbufferCI.renderPass = nullptr; gbuffer = graphicsWrapper->CreateFramebuffer(gbufferCI); // Bind glBindFramebuffer(GL_DRAW_FRAMEBUFFER, fbo); // Draw here... // Bind to textures glActiveTexture(GL_TEXTURE0); glBindTexture(GL_TEXTURE_2D, textures[0]); glActiveTexture(GL_TEXTURE1); glBindTexture(GL_TEXTURE_2D, textures[1]); glActiveTexture(GL_TEXTURE2); glBindTexture(GL_TEXTURE_2D, textures[2]); glActiveTexture(GL_TEXTURE3); glBindTexture(GL_TEXTURE_2D, depthrenderbuffer); Here is an extract of my code. I can't think of anything else to include. I've really been butting my head into a wall trying to think of a reason but I can think of none and all my research yields nothing. Thanks in advance!
    • By Adrianensis
      Hi everyone, I've shared my 2D Game Engine source code. It's the result of 4 years working on it (and I still continue improving features ) and I want to share with the community. You can see some videos on youtube and some demo gifs on my twitter account.
      This Engine has been developed as End-of-Degree Project and it is coded in Javascript, WebGL and GLSL. The engine is written from scratch.
      This is not a professional engine but it's for learning purposes, so anyone can review the code an learn basis about graphics, physics or game engine architecture. Source code on this GitHub repository.
      I'm available for a good conversation about Game Engine / Graphics Programming
    • By C0dR
      I would like to introduce the first version of my physically based camera rendering library, written in C++, called PhysiCam.
      Physicam is an open source OpenGL C++ library, which provides physically based camera rendering and parameters. It is based on OpenGL and designed to be used as either static library or dynamic library and can be integrated in existing applications.
       
      The following features are implemented:
      Physically based sensor and focal length calculation Autoexposure Manual exposure Lense distortion Bloom (influenced by ISO, Shutter Speed, Sensor type etc.) Bokeh (influenced by Aperture, Sensor type and focal length) Tonemapping  
      You can find the repository at https://github.com/0x2A/physicam
       
      I would be happy about feedback, suggestions or contributions.

  • Popular Now