Jump to content
  • Advertisement
Sign in to follow this  
M4573R

Fillrate speed problems

This topic is 3173 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

If I need to render any sort of large, transparent, layered planes, it kills framerate. But I need this for things like fake light volumes. Is there any techniques for getting around this? Or rendering modes that will speed it up? (like smaller render targets)

Share this post


Link to post
Share on other sites
Advertisement
Smaller render targets would certainly help. If you can disable Z-testing or use stencil culling that should speed things up too.

Share this post


Link to post
Share on other sites
Well I need z-testing. I'd like to make my render target smaller and blur it, but since I'm testing depth, it causes some issues. I render these planes with depth-testing to their own render target. However if I blur this and render it over the scene, I get blurred silhouettes wherever the planes failed the depth test. I need to somehow blur my render target, then render the whole thing with depth testing. How do I check depth when I'm just rendering a post-processed image on a plane? Another depth buffer? If I could do this, then I can turn off z-testing while rendering all the actual planes, and just do it when rendering the final image.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!