Jump to content
  • Advertisement
Sign in to follow this  
tavati

textures in directx 8.1

This topic is 3098 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

when i create models in blender or autodesk in 3ds format and convert them with conv3ds and then use the x file in my code the texture only shows the basic colour of what i used. the shine is not there. But when i load the sample model which came with the SDK which uses the same bmp file for texture it has that shine when i use it in my sample code. Also i am using two meshes. one my own model and the other is the sample. when i do that my own model shows the shine but when i replace the sample model with my own model using the same texture bmp file, the shine is lost on both the objects when rendered in the sample code. i use vc++ 6.0 . i am sure i am missing somegthing very basic in making models for directx. any hint or full soln wil be very helpful.

Share this post


Link to post
Share on other sites
Advertisement
I'm not sure what you mean by "shine". If you refer to the lighting, it's possible that your model doesn't have normals, or has incorrect normals, and so you don't get the lighting right.

BTW, why VC++ 6 and DX8.1? That's really old tech and would make getting help harder.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!