Archived

This topic is now archived and is closed to further replies.

JeroMiya

CodeWarrior Pro 6.0 and Lesson 1

Recommended Posts

I can''t get lesson 1 to link in CodeWarrior Pro 6.0. I tried to open up the codewarrior pro 5 project in 6(trying to compile for windows), and it gave me an error when I tried to compile: Link Error : Undefined symbol: _WinMain@16 in MWCRTLD.LIB (winmaincrt.obj) I also tried creating a new prokect and then adding the OpenGL libraries, but that didn''t even compile (misc errors). Does anybody know how to get a working OpenGL project in CodeWarrior Pro 6.0? I''m currently using the MacOSX version, but I also have the windows version and it gave me the same error when I tried it there.

Share this post


Link to post
Share on other sites
Oh.. I HATE that link error. I too use code warrior. I have to think about how I solved it though. It was something really stupid. I think it''s something like changing the target type in the project link settings. There should be options like native, consol, and such. I suggest you try native, it let''s the problem try to solve itself. If I realize that was wrong and remember a different way I delt with it, I''ll post. Though I''m pretty sure that was it. I think the setting was linker subsystem under the project settings. Just try all the options until you hit one that works. Though it SHOULD be windows gui or native. Good luck with it, I know how FRUSTRATING that can be.

Alex Broadwin
A-Tronic Software & Design
-----
"if you fail in life, you were destined to fail. If you suceed in life, call me."
"The answer is out there."
"Please help, I''m using Windows!"

Share this post


Link to post
Share on other sites
No luck eh? Ok, try making a new win32 project and adding the libs yourself. Perhaps this is something residual from the old version of the project. I know it converts it, but maybe there''s something it doesn''t think is an error. Good luck with it.

-Alex

Alex Broadwin
A-Tronic Software & Design
-----
"if you fail in life, you were destined to fail. If you suceed in life, call me."
"The answer is out there."
"Please help, I''m using Windows!"

Share this post


Link to post
Share on other sites
Yes, as I said, I tried both ways. I tried creating a new Win32 project and adding the libs, but when I did that, I couldn''t get the project to compile. I don''t think I added the libs right though, because the normal libs have a different icon. When I "Add Files" and added the opengl libraries, the had the text file icon rather than the library icon. Is that not the right way to import a library? Anyway, I tried to compile it, but I got compile errors, not just a link error, which makes me think I didn''t add the libs correctly. I think I''ll also try downloading the Visual C++ project and using those source files instead of the CodeWarrior Pro 5 project''s source files as they might not be in sync.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Hi,
I just wanted to say that i have been trying to get
Codewarrior Pro 6.0 to work with the lessons and i can''t get it to compile without errors either. I''ve tried all i can think of, but i continuously get denied using the codewarrior 5 code . If someone knows how to get it running, please, please post it. thanks!!!

Share this post


Link to post
Share on other sites