Jump to content
  • Advertisement
Sign in to follow this  
xilup

Multisampling and Lines

This topic is 2716 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I need to draw some raw lines(a string of pixels), but it seems that multisampling keeps messing my lines.It makes them thicker and almost transparent.Is there a way of glEnable() and glDisable() multisampling or drawing lines without that happening? Thank you, xilup.

Share this post


Link to post
Share on other sites
Advertisement
Quote:
Original post by Hodgman
It's been a while since I've dealt with this, but you could try glDisable( GL_LINE_SMOOTH )


Don't think it would do too much, since i am using multisampling.However, what i am trying to do is a 2D game, so i don't think multisampling is really necessary here, since almost all of my quads will be textured.

Share this post


Link to post
Share on other sites
This topic may be quite old, but for these that needs this, GL_LINE_SMOOTH fails now under nVidia... I directly disabled GL_MULTISAMPLE_ARB and it worked (GL_MULTISAMPLE_ARB is defined in GLEW)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!