Jump to content
  • Advertisement
Sign in to follow this  
XTAL256

Getting 2 WM_LBUTTONUP messages on mouse up

This topic is 3102 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I just realised that my game is getting 2 WM_LBUTTONDOWN and WM_LBUTTONUP messages every time i press or release the mouse button. I noticed it when i was debugging and saw that a method that was getting called when the game was started was getting called twice. And this was because two consecutive mouse up events were being generated when i clicked the "Start" button. I am using SDL, and my own GUI system, but the messages are coming from Windows. I can see it in Winspector Spy. Two WM_LBUTTONDOWN messages when i press down, then two WM_LBUTTONUP messages when i release. But the funny thing is that when i click any other button it doesn't happen. I don't think i am sending any messages or anything like that, i am not calling SDL_PushEvent. Anyone have any idea what could be causing this?

Share this post


Link to post
Share on other sites
Advertisement
I don't think so. What's a desktop accelerator?
Naturally, it isn't happening with any other programs' windows that i inspected. I suspect it could be something to do with SDL

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!