Archived

This topic is now archived and is closed to further replies.

ManFriday

BSP skybox question

Recommended Posts

ManFriday    122
Sorry about so many questions today, but i ran across another issue. I created a small level (some castle walls and a couple towers) in Q3Radient. When I pull it into lstudio, the textures for the skybox are visible. Basicly, Theres a big blue box encircling my castle. I have gone throug and read past messages from other folks who had the same problem, but they never really stated what they did that fixed it, just that they got it working. I follwoed the instrictions in the lstudio documentation, but it is simply not working. the sky.shader file has had the surfaceparm sky uncommented, so i dont think that is the problem. I have placing the .bsp file, the shader file and the textures all in one directory and doning the conversion. I tried placing the textures in a \textures directory and the scipt in a \script directory, both as sub direcotories of the folder which the .bsp and the conversion utility reside. Im fresh outta ideas. can anyone tell me what I might be doing wrong? thanks. Jason

Share this post


Link to post
Share on other sites
ChrisE    184
I would uncomment all references to surfaceparm sky in the sky.shader file. This way no matter which sky texture you use it will work properly.

Share this post


Link to post
Share on other sites
ManFriday    122
OK. so my problem was that I was searching the sky.shader file for referneces to surfaceparm sky, and ensuring that they were not commented out.

However, upon closer inspection of the sky.shader file I saw that in the section for the texture I was using there was no reference to surfaceparm sky.

adding the line fixed the problem, so once again my problems were the result of my own stupidiosity.

thanks for your help.



Jason

Share this post


Link to post
Share on other sites