• Advertisement
Sign in to follow this  

Possible: D3D10 + Sprites + fonts ?!

This topic is 2926 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I've been running into an annoyance when combining font rendering calls with sprite batch rendering during my rendering sequence. I'm using d3d10 and I've verified that my rendering of fonts and sprites actually produces results that i can see (and expect) the problem is combining them .. if i render text and then a sprite, only the text is visible. it looks like the state of my d3d10 device is being messed up after rendering text is there something i need to do to prevent this? or is this caused by something I've overlooked? thanks

Share this post


Link to post
Share on other sites
Advertisement
I think i recall having this issue in dx9...

When you render the text, does the code for that reside within the same render pass as the image rendering code?

Share this post


Link to post
Share on other sites
hi,
yeah it's all happening within the same render loop and the calls to font and sprite render are virtually right next to each other. I'm just trying to set up a basic ui for my application.

Something has just come to mind; do I need to have a shader bound to the device when rendering sprites/font text in d3d10? In d3d9 I'm able to render directly to the render target, but d3d10 seems to be highly 'shader centric' which is why I ask.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement