Sign in to follow this  
Aiwendil

Unresolved External Symbols with Debug Builds Only

Recommended Posts

Aiwendil    158
Hi everyone, My game compiles properly when I'm building in Release mode in Visual Studio 2008 Pro, but when I try to build in Debuge mode, I get several unresolved external symbols. Most seem to be centered around _CrtDbgReportW. error LNK2019: unresolved external symbol __CrtDbgReportW referenced in function "public: class Sprite & __thiscall std::vector<class Sprite,class std::allocator<class Sprite> >::operator[](unsigned int)" (??A?$vector@VSprite@@V?$allocator@VSprite@@@std@@@std@@QAEAAVSprite@@I@Z) error LNK2001: unresolved external symbol __CrtDbgReportW error LNK2001: unresolved external symbol __CrtDbgReport error LNK2001: unresolved external symbol __CrtDbgReportW error LNK2019: unresolved external symbol __malloc_dbg referenced in function "void * __cdecl operator new(unsigned int,struct std::_DebugHeapTag_t const &,char *,int)" (??2@YAPAXIABU_DebugHeapTag_t@std@@PADH@Z) error LNK2001: unresolved external symbol __malloc_dbg error LNK2019: unresolved external symbol __free_dbg referenced in function "void __cdecl operator delete(void *,struct std::_DebugHeapTag_t const &,char *,int)" (??3@YAXPAXABU_DebugHeapTag_t@std@@PADH@Z) error LNK2001: unresolved external symbol __free_dbg error LNK2019: unresolved external symbol __calloc_dbg referenced in function __Getctype Most of these are listed as being in the libcpmtd.lib file. Any ideas on how to fix this? I recently upgraded from Vista to Windows 7 and had to reinstall everything. Could this have caused the problem? Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this