Sign in to follow this  
churroloco

Including d3d10.lib in Static lib

Recommended Posts

churroloco    100
Hello I am having a difficult time including d3d10.lib into my project. My visual studio solution has two project one static library (The engine) and one executable project (engine test project). I first tried to include the d3d10.lib into the static library but realized that wouldn't work. I then tried to include d3d10.lib into the executable project but it keeps saying it can't open d3d10.lib. Here is what I have don't. 1.) Only installed latest February build of DirectX SDK 2.) Set the LIB path in Tools->Options->Project Directtories to "C:\Program Files (x86)\Microsoft DirectX SDK (February 2010)\Lib\" ( I even tried setting it to the subfolder x86 and x64) It still says it can't open the libs. Any ideas?

Share this post


Link to post
Share on other sites
cache_hit    614
In theory the installer should set the paths for you BUT just in case you can set them manually as you mentioned. But be advised that you set it twice -- once for x86 and once for x64. Just use the little dropdown in that same dialog. Make sure its the FULL path to the .lib including the x86/x64 depending on whats selected in the drop down.

Specify the .lib in the exe project and if it still doesnt link turn on verbose output in advanced linker settings

Share this post


Link to post
Share on other sites
churroloco    100
Well, I added both full paths x86 and x64. I'm pretty sure it should be using 32 though since the platform is Window32.

Also, I set the output to verbose mode but didn't get anything more

Here is the build log:
Linking...
LINK : fatal error LNK1104: cannot open file 'd3d10.lib

Also I tried differentiating then integrating and I only seemed to get the same function back. Just in case, I set Epsilon just above 0. I still got the linking error.

Could anything information help?

Share this post


Link to post
Share on other sites
churroloco    100
Here is some more info...

Linker->Input:
"d3d10.lib, d3dx10d.lib, ../debug/CatacombEngine.lib"

Tools->Options->Project Directories->LIB option
C:\Program Files (x86)\Microsoft DirectX SDK (February 2010)\Lib\x86
C:\Program Files (x86)\Microsoft DirectX SDK (February 2010)\Lib\x64

Share this post


Link to post
Share on other sites
mattd    1078
Use spaces to separate library names in the linker Input field, not commas.

d3d10.lib d3dx10d.lib ../debug/CatacombEngine.lib

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this