Sign in to follow this  
matthughson

[XNA] Blurry Fuzzy Textures

Recommended Posts

Hi, We are finding that some of our game textures are showing up quite blurry. I believe that this is due to mip mapping, or filtering of some sort. This is great for most textures in our game, but this texture in particular contains text, which becomes unreadable. Here it is: This is the source texture: Any idea how I can turn off filtering, or whatever is going wrong, with this material? I am using XSI and the default Phong.fx shader that comes with XNA. Thanks!

Share this post


Link to post
Share on other sites

You can turn off mipmap generation for a texture in Game Studio by opening it's properties from the content folder and under Content Processor setting Generate Mipmaps to false.

That is looking really, really blurry though. Are you sure filtering is the issue here, or are you perhaps drawing it at a very different aspect ratio from the original?

Share this post


Link to post
Share on other sites
Quote:
Original post by remigius

You can turn off mipmap generation for a texture in Game Studio by opening it's properties from the content folder and under Content Processor setting Generate Mipmaps to false.

That is looking really, really blurry though. Are you sure filtering is the issue here, or are you perhaps drawing it at a very different aspect ratio from the original?


Thank remigius,

Unfortunately, these models are being processed through the XSI content pipeline, which loads the textures manually. The textures are not processed through the Solution file like other model formats, so I can't set any settings on it in there.

I believe the texture is so blurry in this case because it's quite far from the camera (i've cropped the screen shot), and thus using a very small mip-map.

Thanks!

Share this post


Link to post
Share on other sites
I don't think there's going to be a good way for you to make that particular texture work for the scenario in which your drawing it. Linear interpolation will quite simply destroy high-frequency details likes text. Really the best fix you can do here is either crop the texture or alter the UV's of your geometry so that the texture doesn't have to be scaled vertically.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this