• Advertisement
Sign in to follow this  

SetCooperativeLevel in Windows 7

This topic is 2922 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, I am currently developing an .ax filter - Direct Draw based VGA Render. All works fine. But in Windows 7 when I run this filter "Aero" is turning off some how. I don't no why, but it is occurred after SetCooperativeLevel() function called. Is there some special flags for SetCooperativeLevel() to avoid this? Thanks, Sergey

Share this post


Link to post
Share on other sites
Advertisement
I'm fairly sure you can't run DirectDraw applications with Aero going, that's why it switches to basic mode when you make that call.

Share this post


Link to post
Share on other sites
I really wouldn't use DirectDraw; it's emulated using D3D on Vista+ anyway. As Flimflam said, I don't think you can run DirectDraw apps with Aero.

Share this post


Link to post
Share on other sites
Oh, this is sad. I hoped what this problem can be resolved, because when I used DDSCL_SETDEVICEWINDOW flag in SetCooperativeLevel I saw what "Aero" still switched on. But after, CreateSurface returns DDERR_NOCOOPERATIVELEVELSET error. Thank you for help. I think I need to find another way.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement