Sign in to follow this  
Black Knight

Dark Age Version 0.4.1101 Released!

Recommended Posts

The new release of my game is ready after two months.Here are the download links and the change log.Have fun and please let me know if you encounter any bugs or crashes. I need help with character models and animations so if you think you can help just drop a message or send an email. Download : Dark Age v0.4.1101 Videos : Editor on YouTube Game on YouTube Changelog : Dark Age Change Log Screenshots:

Share this post


Link to post
Share on other sites
Wow, good work. I really envy you for releasing a rpg ! I watched your announcements for some time and I'm quite impressed by your progress.

I work on my own (not released) rpg on a similar timescale, so I collected some links to helpful art themes. Here are some link which might be helpful for your tasks:
- A huge motion cap library
- MakeHuman, a poser like human modelling tool
- Mapzone, free procedural texture generation tool
- Orc texturing tutorial

If you invest some time in blender you could get good results with makehuman and the mocap library. With a rig (mocap) and a model (makehuman -> use polyreduction to reduce poly count) you can produce very good skinning results with bone-heat-skinning.

Please pay attention to the according licenses.

Good luck :-)



[Edited by - Ashaman73 on February 22, 2010 8:50:45 AM]

Share this post


Link to post
Share on other sites
Looking pretty good, nice job. Too bad I couldn't see the game in action as it keeps throwing this message at startup:

Error message:
Can't add effect file terrain.fx (Couldn't get compilation errors)

File: .\src\DirectX\D3D9Renderer.cpp
Function: STE::D3D9Renderer::addEffect
Line: 289
----------------------------------
STEngine

Might be useful information or not, but I'm using a mobile Radeon HD card with up-to-date drivers and DirectX 11.

Share this post


Link to post
Share on other sites
A friend discovered a bug in the game which pops out when you save the game and quit.When you open the game again and load the game from the main menu all the animations play ultra fast there is probably something wrong with the way things are initialized when the game is loaded from the main menu as it works if you load from inside the game.

Anyway anyone else tested the game and found other bugs?

Share this post


Link to post
Share on other sites
Sign in to follow this