Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

core114

glPolygonOffset

This topic is 6190 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

i am drawing a square-ish tile made out of two traingles, then redrawing it with blending on to show it is selected i am using glPolygonOffset to prevent problems with zbuffering however, when it is partly off of the screen it doesn''t work right, and there are what look to be z buffer problems it works fine otherwise is there some problem with using glPolygonOffset with clipped geometry? any help would be usefull

Share this post


Link to post
Share on other sites
Advertisement
If it some problems should it be the driver. Do some more testing so you will know for sure what is not working.

Share this post


Link to post
Share on other sites
glPolygonOffset is quite a hard beast to get right. one possible reason is when a polygon is clipped the geometry does not go through the same pipelineand thus even though u use the same vertices u end up getting different depth values

Share this post


Link to post
Share on other sites
If you''re redrawing the tile over itself to look different so the user knows which tile is selected try drawing the tile only once, but just tinting it a different color or something.

use glColor*f before you start drawing.

------------
- outRider -

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!