Jump to content
  • Advertisement
Sign in to follow this  
loachman

Error installing Allegro in codeblocks

This topic is 3123 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I am using the MinGW compiler it is installed and working with codeblocks.I however get this error when trying to get allegro to compile. c:\MinGW\allegro>fix mingw32 Configuring Allegro for Windows/MinGW... Done! c:\MinGW\allegro>mingw32-make Compiling Allegro for MinGW32, optimised. Please wait... gcc -Wall -Wno-unused -I. -I./include -x assembler-with-cpp -o obj/mingw32/alleg /icpus.o -c src/i386/icpus.s src/i386/icpus.s: Assembler messages: src/i386/icpus.s:70: Error: suffix or operands invalid for `fnstsw' mingw32-make: *** [obj/mingw32/alleg/icpus.o] Error 1 c:\MinGW\allegro> It works with fixmingw32 But when I use mingw32-make it does not compile. Thanks

Share this post


Link to post
Share on other sites
Advertisement
Quote:
But when I use mingw32-make it does not compile.
Don't use the make from mingw. You should have installed MSYS and used the make provided by MSYS.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!