Archived

This topic is now archived and is closed to further replies.

Dynamite

FPS problem with 2 different gfx cards

Recommended Posts

Dynamite    145
I have a problem with my game, I''m using DX8 in windowed mode. I have a 4MB AGP built-in Rage card and i get about 140fps. I just bought a new 32MB card (PCI because I have an crappy eMachine with NO AGP slots). The problem is that I''m getting the same fps rate!!! Now I was playing Black and White, and the new card is CLEARLY better than the 4MB, so does anyone know what could be causing this? I KNOW the card is working, just not with my game. I''m using VC++ 6.0. If anyone can help, I would GREATLY appreciate it.
--I don''t judge, I just observe Stuck in the Bush''s, Florida

Share this post


Link to post
Share on other sites
Dynamite    145
Compusa card. I went to just get SOMETHING, and they had them there. It''s an SiS300/305 card. I understand fps doesn''y HAVE to go up, but why do other games go up and not mine? Does it have something to do with my initialization if DX? I''m doing it like in the SDK.

p.s. yeah I REALLY wish I had an AGP slot !!!!



--I don''t judge, I just observe

Stuck in the Bush''s, Florida

Share this post


Link to post
Share on other sites
CrazedGenius    156
Could it be that whatever your doing is constrained by something other than graphics pipeline stuff? For instance, if you were constrained by physics calculations, a better card wouldn''t help. Likewise, if you are bandwidth constrained, getting a better card still might not help if the PCI bandwidth was the problem. Different games have different bottlenecks.

There is a chain of stuff your graphics go through before they vomit onto the screen (CPU, bus, graphics pipeline, etc.). Find the weakest link in the chain, unravel the mystery, win a prize.

Share this post


Link to post
Share on other sites
Dynamite    145
Thanks guys, I''m going to mess around with my code a little to see what happens.



--I don''t judge, I just observe

Stuck in the Bush''s, Florida

Share this post


Link to post
Share on other sites
Dynamite    145
quote:
Original post by simon_brown75
Maybe 140 is the refresh rate of the monitor, in which case you need to turn off v-sync before your app can go faster.


The refresh rate is 60Hz, and increasing to 80 does not help. Also, I can''t seem to find V-Sync, is there something special I have to do? I was searching under Device Manager and found nothing.




--I don''t judge, I just observe

Stuck in the Bush''s, Florida

Share this post


Link to post
Share on other sites
simon_brown75    123
If your refresh rate is 60 Hz, or even 80 Hz, and your program is running at 140 fps, then v-sync must already be off. V-sync is usually in the video card options (usually in display properties->settings->advanced).

Edited by - simon_brown75 on August 5, 2001 9:59:39 AM

Share this post


Link to post
Share on other sites