Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Kylotan

Just in time debugging question

This topic is 6191 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have MSVC6 and Borland C++ Builder 4 installed. I didn''t ask Borland to do this, but it changed my system so that the just-in-time debugging now uses its poxy excuse for a debugger rather than the one in Visual C++. I''d like to change this back, but can''t find a way of doing so in the options. Does anybody have any hints?

Share this post


Link to post
Share on other sites
Advertisement
From Jeff Richter''s book:

"Internally, UnhandledExceptionFilter invokes the debugger by looking into the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\NT\CurrentVersion\AeDebug
Inside this subkey, there is a data value named "Debugger", which is typically set to the following value when you install Visual Studio:
...\msdev.exe -p %ld -e %ld

WINDOWS 98: These values are stored in the Win.ini file."

Share this post


Link to post
Share on other sites
Hmm...Reinstalling MSVc wouldn''t work... I guess the only thing left to do is remove Borland...

That is, unless a Borland guru has a better solution for you.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!