Sign in to follow this  

open gl fails to change color state

This topic is 2830 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am novice to open gl and I'm using jogl to do some drawing. In the official open gl specification book and other sites it says once you called the function glColor3f(some color), that 'some color' will be used for drawing primitives there after. So a call to glVertex2f(x, y) should actually create a primitive with that color. The problem is that the color I used to initially draw a primitive persists no matter how many times I called glColor*f(). I even copied the Sample.java from http://today.java.net/article/2003/09/06/jumping-jogl#comment-13887 I deleted the files that are connected to the image and animation part but used the rest of the code as it is. Odd as it may sound, all the primitives got displayed on 'red' color. This is just some thing to odd to understand for me.What could possibly wrong????

Share this post


Link to post
Share on other sites

This topic is 2830 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this