Archived

This topic is now archived and is closed to further replies.

nanobyte

Fullscreen FPS Problem

Recommended Posts

As I was writing my game engine in dx8, I noticed that when going to fullscreen mode, the frame rate drops by more than double. For example, running the game in windowed mode results in about 400 fps, while in fullscreen, that drops to 80fps at 640 x 480 32 bit. This is a simple 2d game as well. I thought that it might just be my program, so I ran the dolphin demo that comes with the sdk, and changed it to fullscreen and the same thing happened. Here are my specs: win2k geforce2 pro 64mb abit kt7 via kt133 amd 10000mhz I have updated the 4-in-1 drivers and I am using the detonator 12.90 drivers. Any suggestions?

Share this post


Link to post
Share on other sites
There is overhead associated with flipping backbuffers. But in your case I''d try turning off vsync (vertical blank syncronization).

PS: quite an amazing overclock you pulled off there, 10Ghz; wow! Liquid nitrogen cooled I assume?



The quickest way to double your money is to fold it in half and put it back in your pocket.

David Hof
Genesis3D Classic engine programmer
mail - icq - homepage

Share this post


Link to post
Share on other sites
Yea, that seems to be the problem. But where can I disbale vsync, there is an option to disable it in the "opengl" section of the display control panel, but I can''t find it for dx.

Share this post


Link to post
Share on other sites
Thanks! I edited the registry so that I could disable vsync (found tutorial on google) and my fps in my game went from 80 to 750fps.

Share this post


Link to post
Share on other sites