Sign in to follow this  

d3dx9.h problems

This topic is 2817 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

My self also had been suffering from this same problem as a lot of you guys and girls but finally sorted, so i am sharing how incase any one else becomes unstuck it may be a bit over kill but what i have ended up doing was to simply copy and past the entire "include" & "lib" folders from the directx sdk into the vc 9.0 folder and have done the same for the dark GDK. As i said may be a bit overkill but it sorted the problem out and now works just fine. good luck all

Share this post


Link to post
Share on other sites
That is the wrong way to do this. The correct way is to add the paths to the original include and lib folders to the IDE's search tools, via Tools -> Options -> Projects and Directories.

Share this post


Link to post
Share on other sites
Or if you want to do it on a per-project basis, like this.

As Josh says, it's horribly wrong to put things in the include directories of your compiler. Not only will it mess up the order things are included in, it has the risk of shadowing and clobbering system headers, which definitely is not a good thing.

For some deranged reason, Lazyfoo used to say to do things like you said, but he saw the error in his ways and reverted to sanity. Heck, he even has a fancy visual guide on how to do it, with fancy screenshots and all. Just don't deploy DLLs to the system folder as he says, that would be horribly wrong too.

Share this post


Link to post
Share on other sites
Just notice that "Projects and Solutions" settings are separate for x64 and regular 32bit compilations. But once you set them up, you're good to go. Takes no more that 5 minutes max. Do NOT copy any header or library files on top of headers from VS or from platform SDK.

Share this post


Link to post
Share on other sites
It might also be worth noting that I've found I have to move the DX directories to the bottom of the list of directories Tools->Options->Projects and Solutions->VC Directories to prevent some strange errors. Not sure why, but for some reason on my rig I need to have the DX directories after the PSDK directories in both the Include and Lib sections.

Share this post


Link to post
Share on other sites
thanks guys looks like i have some undoing to do and some learning on how to do it the right way thanks for the heads up..


works a treat thank you so much for the guidence still a noob at this and look forward to getting my teeth stuck into dame programing

[Edited by - creativereble on March 30, 2010 9:46:24 PM]

Share this post


Link to post
Share on other sites

This topic is 2817 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this