Sign in to follow this  
Teph117

udk, 3ds max, and speedtree help

Recommended Posts

Teph117    100
ok i have a couple of questions having to do with udk and 3ds max as the title says. first of all i am a beginner and im still learning alot my first question is in udk im having a problem with some of my textures and when i add the textures it either doesnt show up when i text the level or it makes the item i put it on completely invisible or even black but shows up ok as long as im not testing the level. is there any reason for this? or any way to fix it? my next question is i made a static mesh for grass using 3ds max using hair and fur but after i export it and then import it into udk i dont know how to keep all of the colors/textures and the hair and fur is no longer there, how do i keep these things there. and also dealing with this, when i do put the mesh into the level it shows up in the editor but it isnt there at all when i test it, all there is, is 2 small shadows where i placed it my last question is with speedtree, i made my trees ok and added them to my level but for some reason the trees arnt there when i play it,but it is ok when i just "test from here" kinda like my static mesh i made, all it shows is the shadow but no object is there if anyone can help me with any of these issues i would appreciate it a lot. Thanks in advance

Share this post


Link to post
Share on other sites
So on the black textures and invisible textures you want to make sure that your texture mode is on unlit in the texture editor, and then assuming that is true you want to use a dominant directional light to build your level.

If the dominant light doesn't match your level theme you can always remove it when the time comes.


Fur rendering in UDK is an advanced topic. Your export through ActorX I assume will save your texture coords but you;re still going to have to create and apply the materials in the UDK.

Make sure your editor is in preview mode when you choose "Play from Here" so that it matches what you'll see in-game. Also make sure if you're using a custom game type, and you should be, that the PIE option is set to your game type.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this