Archived

This topic is now archived and is closed to further replies.

Combat-Wombat

Undefined Symbol: _WinMainCRTStartup

Recommended Posts

Combat-Wombat    122
I''m trying to get used to this DirectX thing, but it isnt going too well... I''ve tried 2 differnt example codes just to draw a window, and both give me the same error. "Link Error: Undefined Symbol: _WinMainCRTStartup in module entry point" I''m using CodeWarrior Pro 5. I''ve added the directXsdk\include and directXsdk\lib directories for where it searches for files. I then linked the whole lib directory just to make sure I didnt miss anything... =) I checked and I DID make it a Win32 Ap...not console. Any ideas?

Share this post


Link to post
Share on other sites
SikCiv    122
I had that error once, though I''m not exactly sure how I fixed
it Try the following:

* Make sure you startup function is WinMain() and not main().
* Make sure you add the required non-DX Libs to your link
settings. Check the makefiles in DXSDK sample projects for
the lib names you need.

Hope this helps

  Downloads:  ZeroOne Realm

Share this post


Link to post
Share on other sites
Combat-Wombat    122
My main function is indead WinMain and I''ve included lots of different libs to no effect. I''m taken to including them at random just to see if it would work, but no dice. Any other ideas?

Share this post


Link to post
Share on other sites
SikCiv    122
Try:

* Making sure you are using the correct Lib types, i.e. if you are compiling in debug mode, use the Debug versions of the lib files.

* Cleaning all the temporary files and do a fresh compile.

* Looking up ''WinMainCRTStartup'' in your compilers'' help and include the libs and header files the function requires.

* Make sure you are not including two different versions of lib and header files in your LIB and INCLUDE paths.

  Downloads:  ZeroOne Realm

Share this post


Link to post
Share on other sites