Sign in to follow this  
Black Knight

Strange errors with VS2008

Recommended Posts

Black Knight    769
Last night everything was compiling fine.This morning I started getting whole bunch of errors when I tried compiling my programs. Here is the minimum program that causes the problem :
#include <map>


int main()
{
	return 0;
}


I get more than 100 errors here are a few of them :
Error	1	error C2993: '_Arg0' : illegal type for non-type template parameter '_C_CLASSOFARG0'	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	329
Error	2	error C2065: '_Farg0' : undeclared identifier	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	329
Error	3	error C2059: syntax error : '>'	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	329
Error	4	error C2143: syntax error : missing ';' before '{'	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	331
Error	5	error C2143: syntax error : missing ';' before '}'	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	333
Error	6	error C2649: 'typename' : is not a 'class'	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	349
Error	7	error C2649: 'typename' : is not a 'class'	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	359
Error	8	error C2649: 'typename' : is not a 'class'	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	368
Error	9	error C2649: 'typename' : is not a 'class'	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	378
Error	10	error C2649: 'typename' : is not a 'class'	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	401
Error	11	error C2649: 'typename' : is not a 'class'	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	411
Error	12	error C2649: 'typename' : is not a 'class'	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	420
Error	13	error C2649: 'typename' : is not a 'class'	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	430
Error	14	error C2649: 'typename' : is not a 'class'	c:\program files (x86)\microsoft visual studio 9.0\vc\include\xxresult	453



I have visual studio 2010 installed on the machine too but it was installed like a week ago and everything was working till today.I have visual studio 2008 SP1 installed and the same application above compiles fine in visual studio 2010

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this