Jump to content
  • Advertisement
Sign in to follow this  
aswin1980

[SlimDX]turn off Antialias

This topic is 3032 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, Im trying to render video using SlimDX. The video that is rendered contains smooth edges whereas when the same video is rendered using ManagedDirectX seems to be Jagged. Could you please let me know whther by default ManagedDirectX turns off Antialias. If i want to turn off AA in SlimDX how to do it. I have tried SetRenderState with multisample antialias and line. still no use. Thanks, Aswin.N.Paranji

Share this post


Link to post
Share on other sites
Advertisement
Antialiasing in D3D only affects polygon edges, which I suspect you won't have many of in your video.

What you want to change is the texture filter. Try point filtering to get blocky results.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!