Jump to content
  • Advertisement
Sign in to follow this  
SiS-Shadowman

Building boost

This topic is 3089 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I can't get boost to build and the only output I'm gettning is: warning: Unable to construct ./stage-unversioned ...found 1 target... The first line appears multiple times, depending on the build type (complete, debug only, etc...). I'm running on Windows 7, trying with Visual Studio 2008 and 2010 with the same result. (both times using the appropriate promt-bat). These are the commands I've tried: bjam toolset=msvc [--build-type=complete] [stage] bjam toolset=msvc-9.0 [--build-type=complete] [stage] bjam toolset=msvc-10.0 [--build-type=complete] [stage] Anyone else experienced this and knows a solution?

Share this post


Link to post
Share on other sites
Advertisement
1) Do you include [ ] in the command? If so, try without. Toolset should be msvc.
2) Is the folder you are building in writable? Try running with admin rights.
3) Is the compiler on the path. As in, if you write cl at the prompt, do you get a response or a 'command not found'?

Share this post


Link to post
Share on other sites
1. I added the [] in my post to indicate that I tried any combination of those (I didn't include them in my commands)
2. I suppose it is writable. I can create and delete files/folders without a problem. I just ran the command prompt with admin rights, but it didn't make any difference, I still get the same warning
3. Both cl and link are available with my current prompt, still boost won't build

*Edit*
It seems it was a problem with write permission, but I don't understand why bjam cannot create a folder, even when run with admin rights.
Viewing the properties of the boost folder revealed that some files were read-only (it showed the square to indicate that something is read-only, but not everything). I removed the read-only flag for every file & folder inside boost, and now bjam seems to be working, at least it is compiling now.
Tanks for the help :)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!