Archived

This topic is now archived and is closed to further replies.

Still having driver problems

This topic is 5972 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Well, since I still can''t figure this out, and the answer would help both of us (Drakonite and I), I decided to post this not-quit-linux-gamedev question (as in: just about linux ). Anyway, here''s the problem: with Slackware 8.0 (kernel 2.4.5) the NVidia kernel module fails to load due to unresolved symbols. Specifically:
  • __global_cli
  • __global_save_flags
  • __global_restore_flags
  • tqueue_lock Could someone tell me (us) what exactly we have to do to get rid of these errors? My guess would be that another module or two has them, and it needs to be loaded, but we don''t have it. I searched for a long while trying to figure this out, and still haven''t (NVidia won''t help me either ) so any suggestions are welcome . [Resist Windows XP''s Invasive Production Activation Technology!]

    Share this post


    Link to post
    Share on other sites
    Ok, I got lucky (i.e. by messing around) and found a way to fix it. This is what I did, incase anyone else needs this information in the future:

    Make sure you''re out of X (of course) and have downloaded the tarball''s. Then do this:

    cd /usr/src/linux
    make menuconfig dep

    Hit exit, and let it save. Now you wait a while for it to compile. Then you do:

    make clean

    Then wait a while again. Then do:

    reboot

    After you boot back up follow the normal NVidia instructions for installation. I had to do the whole process twice (I think I did something wrong the first time, but I''m not sure what) before it worked. Also, I had to add:

    Option "IgnoreEDID" "On"

    To the Screen section of my XF86Config file. NVidia confirmed that there''s a bug in their drivers that requires this in some cases, you probably won''t need to do this.

    [Resist Windows XP''s Invasive Production Activation Technology!]

    Share this post


    Link to post
    Share on other sites