Archived

This topic is now archived and is closed to further replies.

mutex

visual c++ IDE bug

Recommended Posts

Bug

The Visual C++ 6.0 IDE pops up a message saying "Cannot save file. The file may be in use by another application." about 50% of the time when I try to save a file. The save then fails, but I can try again and it succeeds. I also found out by accident that when the message comes up, the file is or has been deleted, so I must successfully save after or I lose the file.

Conditions

This happens in single and multiproject workspaces. This bug has been with me through hard drive formats, so I don''t think a reinstall will help Regarding the files, yes I have read/write permissions. No, they''re not open by any other program. No, the read attribute is not set. No, the partition is not locked. Yes, my hard drive appears to be working.

System Info

Visual C++ 6.0 Service Pack 5 Windows 2000 Pro Service Pack 2 Using NTFS

...

Has anyone else experienced this? This doesn''t happen in any other program, only the Visual C++ 6 IDE. I can''t remember if I''ve experienced this anywhere else, so it might be some weird combination of stuff that I''ve installed. I lost a winsock interface file I had just spent a couple hours writing and debugging, and the bug is starting to annoy me very much. I have a habit of pressing Ctrl+Shift+S (mapped to Save-All) after making any change because VC++ has crashed at very inconvenient times for me.

Share this post


Link to post
Share on other sites
Now that''s strange ...
I have almost the exact same setup (only difference being VC SP level), and I''ve never experienced that.

~~~~~~~~~~
Martee

Share this post


Link to post
Share on other sites
If you were running Win9x, I''d ask if you had some sort of DOS-level disk caching. But you''re not, so I have no idea. I wonder if MSVC does its own caching... after all, I get stupid messages where I compile something, then click ''run'' and it thinks it hasn''t compiled it yet.

Share this post


Link to post
Share on other sites
The bug seems to have disappeared for now. What''s strange is that it''s been with me for at least half a year

I''m guessing it''s afraid of you guys

Share this post


Link to post
Share on other sites
kylotan > that happens to me as well, it says

so and so file needs to be built or is out of date



--------------------------

Whats a pretty girl like you doing in a dirty mind like mine?

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
I get the problem with "cannot save file..."

I''m running win2k with VS6 Enterprise + SP5.

grrr

Share this post


Link to post
Share on other sites