Jump to content
  • Advertisement
Sign in to follow this  
kenjinsakura

OpenGL Index Buffer can only be of type ByteBuffer?

This topic is 3070 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I'm using vertex buffers and the glDrawElements function on OpenGL ES 1.1 to render my polygons. At first, my index buffer was of type ByteBuffer and it displayed everything fine. But then, I tried rendering a model with 1000~ polygons and it turned out weird. So, I figured byte wouldn't be enough since there'd be 1000*3 indices right? So I changed it to short, of course modifying the related allocation functions. However the model still displayed wierd.

I tried using short for the previous model with 200~ vertices and that was rendering wierd too. Going back to byte fixes it though.

Any thoughts why this is happening?

Thanks

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!