Jump to content
  • Advertisement
Sign in to follow this  
Marcoita

Qt and GLEW don't work!

This topic is 3070 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi all.
I have a qt project with Visual Studio 2008, and when I build the solution the following error appear:

error LNK2019: unresolved external symbol __imp__glewInit referenced in function

but I have inserted the glew32.lib, I have the glew32.dll on Windows 7 and this problem does not disappear...

Can someone help me?

PS: hi all!

Share this post


Link to post
Share on other sites
Advertisement
You need to add GLEW_STATIC to your preprocessor definitions and link with glew32s.lib if you want static linking.

Edit: Sorry, after reading your post again I see you are trying to do dynamic linking. Can't help you there....

Share this post


Link to post
Share on other sites
Where is glew32.lib stored on your machine?
Is it with the project file or elsewhere? If elsewhere have you set the correct path in the linker settings?

Share this post


Link to post
Share on other sites
glew32.lib is in C:\glew-1.5.4\lib and I have this path with Visual Studio, and there is no error of type:
glew32.lib not found

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!