Jump to content
  • Advertisement
Sign in to follow this  
Tingle

(D3DXMATERIAL*)TreeMatBuffer-GetBufferPointer() break in debugger

This topic is 2993 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

In the project release mode, my mesh will load up its textures just fine and run without an error.

But running my project in debug mode, my application will crash at this point:
TreeTempMaterials = (D3DXMATERIAL*)TreeMatBuffer->GetBufferPointer();

The debugger tells me
TreeTempMaterials -> pTextureFilename - CXX0030: Error: expression cannot be evaluated.

Edit:

Did some debugging, my paths are screwed up in debugg mode.
For example to my tree mesh. The path in release is:

F:\Orb\Debug\win32\Media\tree.x
but in debug its:
F:\Orb\Debug\win32\M□

Why is this happening?

[Edited by - Tingle on July 14, 2010 8:15:27 PM]

Share this post


Link to post
Share on other sites
Advertisement
Just a guess. Do you have the project settings for Multibyte vs Unicode different for Debug and Release? Also, the error you posted doesn't seem to match up with the TreeTempMaterials=.. line. Getting a buffer pointer shouldn't result in an evaluation of a pTextureFilename. Post some code around the line where the actual error occurs.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!