Jump to content
  • Advertisement
Sign in to follow this  
pcg4m3s

OpenGL How to import fmod library into OPENGL program (IDE: Visual Studio 2008)

This topic is 2951 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I use Windows XP SP3. I need to import fmod audio library in my project.

I have copied these files:
- fmod64.dll
- fmod.dll
- fmod64vc.lib
- fmodvc.lib
and I pasted them in this directory:
- C:\Programmi\Microsoft Visual Studio 9.0\VC\lib
- C:\WINDOWS\system
- C:\WINDOWS\system32

I have copied these file:
- fmod.h
- fmod_errors.h
- fmoddyn.h
and I pasted them in this directory:
C:\Programmi\Microsoft Visual Studio 9.0\VC\include


[Edited by - pcg4m3s on July 23, 2010 6:10:08 PM]

Share this post


Link to post
Share on other sites
Advertisement
Did you read the error messages? It's telling you there's a syntax error on line 107 in file progettoig.c.

Have you looked at that line and seen what is wrong?

Share this post


Link to post
Share on other sites
Quote:
Original post by AndyEsser
Did you read the error messages? It's telling you there's a syntax error on line 107 in file progettoig.c.

Have you looked at that line and seen what is wrong?


it is not an error. on another computer of my friend it work correctly.

Share this post


Link to post
Share on other sites
Quote:
Original post by pcg4m3s
it is not an error

That is an impressive statement!

Have you tried to link with fmodex_vc.lib? Just including a header and copying a bunch if DLLs does not magically make an external library work.....

Share this post


Link to post
Share on other sites
Quote:
Original post by stalef
Quote:
Original post by pcg4m3s
it is not an error

That is an impressive statement!

Have you tried to link with fmodex_vc.lib? Just including a header and copying a bunch if DLLs does not magically make an external library work.....


my situation is this:
I have a project that is written in C OPENGL by me and another person.
This person added sound with fmod.
When he give me project with his added and I execute it, work correctly, but if i do a save I have error!!!
How is possible this?

look this video of my screen.
you can download it here --> http://jump.fm/YHKXU

[Edited by - pcg4m3s on July 22, 2010 7:04:29 AM]

Share this post


Link to post
Share on other sites
Quote:
Original post by pcg4m3s
NIKOOOOOOOO!!!


wtf????

Also the link you posted just sent me to a shitty page with shed loads of adverts and gay links to other spam. I couldn't see the link to the vid.

It looks like your original post has been edited. What are the errors you are getting? We aren't psychic. The compiler (in general) does a much better job of explaining problems in cases like this.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!