Jump to content
  • Advertisement
Sign in to follow this  
u56237z

VBO random behaviour with large meshes

This topic is 2956 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Im currently experiencing a strange behaviour when modifying meshes with VBO and 'large' objects..

the VBOs are mapped before transformations, and then unmapped.

if the mesh has approx. < 5000 faces, everything is ok, otherwise, after the transformations (and the unmapping) parts of it explode with random vertex positions..

glMapBuffer does never return NULL and glUnmapBuffer always returns GL_TRUE.

It doesnt seems to be a memory issue.. IMHO its a driver-related bug in managing mapping/unmapping of 'large' meshes..

My card is a GeForce 330M with 1Gb VRAM under FreeBSD 8.0 with driver rel. 256.35

any ideas?

PS: I wouldnt call a 10k face mesh 'large' anyway.. but it seems like 5k is the limit.. then everything messes up..

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!