• Advertisement
Sign in to follow this  

SDL_ttf error

This topic is 2732 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi their! I've been following Lazyfoo's awesome SDL tutorials.. And decided I also wanted to load in some fonts. However, after following the tutorials through, I got 4x LNK2019 errors:


1>------ Build started: Project: The Last Guardians - Beta, Configuration: Debug Win32 ------
1> main.cpp
1>main.obj : error LNK2019: unresolved external symbol _TTF_Init referenced in function "bool __cdecl init(void)" (?init@@YA_NXZ)
1>main.obj : error LNK2019: unresolved external symbol _TTF_OpenFont referenced in function "bool __cdecl load_files(void)" (?load_files@@YA_NXZ)
1>main.obj : error LNK2019: unresolved external symbol _TTF_Quit referenced in function "void __cdecl deinit(void)" (?deinit@@YAXXZ)
1>main.obj : error LNK2019: unresolved external symbol _TTF_CloseFont referenced in function "void __cdecl deinit(void)" (?deinit@@YAXXZ)
1>D:\VS Projects\C++\Program 1\The Last Guardians - Beta\Debug\The Last Guardians - Beta.exe : fatal error LNK1120: 4 unresolved externals
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========



I figured the error game from the SDL_ttf library and more specific: TTF_Quit, TTF_OpenFont, TTF_CloseFont and TTF_Init.

I however got no idea what's wrong, anyone who has an idea of what's going on?

Share this post


Link to post
Share on other sites
Advertisement
Quote:
Original post by GenPFault
Are you linking against SDL_ttf.lib?


Yeah indeed forgot that - kind of stupid :S

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement