Sign in to follow this  

[SlimDX] Can't run MiniTri11 sample.

This topic is 2663 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi,

As the subject says, I'm having trouble running the MiniTri11 sample from the June2010 SlimDX SDK. I can build it fine, but it breaks when running at line 52:


Device.CreateWithSwapChain(DriverType.Reference, DeviceCreationFlags.Debug, desc, out device, out swapChain);


with the error message:

"Managed Debugging Assistant 'LoaderLock' has detected a problem in 'C:\Users\Tim\SlimDX Samples (June 2010)\Direct3D11\MiniTri11\bin\Debug\MiniTri11.vshost.exe'.
Additional Information: Attempting managed execution inside OS Loader lock. Do not attempt to run managed code inside a DllMain or image initialization function since doing so can cause the application to hang."

I thought this might be due to my using a dx10 graphics card, so I created a FeatureLevel[] with FeatureLevel10_0 and used the appropriate overload of Device.CreateWithSwapChain but got the same error message.

I'm using VS2008 on vista.

I'd appreciate it if anyone could help with this.

Thanks.

Share this post


Link to post
Share on other sites

This topic is 2663 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this