Sign in to follow this  

Elemental - Gameplay test

This topic is 2656 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello,

I'm in the process of making a 3D platformer game for the PC and Xbox 360. I have reached a stage where i can now share a beta-ish version of my game.

What i'm concerned about is the gameplay itself. So i'm currently using placeholder art and audio. I would very much appreciate it if people could download, play and even send some feedback of what i'm doing right and wrong.

You can download my game from here. This includes the game and the necessary installers. You can download the game only here (i.e. this means you have XNA3.1, .net 3.5 and the latest DirectX runtime API). You can either leave feedback in this thread or you can also leave feedback in the suggestion and bug forms here.

I'm planning on releasing a few more levels which will demonstrate a couple more game mechanics and some better puzzles.

Thanks in advance for your help!

EDIT:
- I forgot to mention this in the readme, you can change the graphics options to make it look nicer (turn shadows on, turn SSAO on, reflections etc.). The default graphics options are set to the lowest settings.
- The web host i'm using is apparently doing a check on my site to make sure it's not malicious (annoying!), so you can also send me suggestions and bugs at ankur_1111@hotmail.com.

Here are some screenshots of the current build:


[Edited by - manxankur on August 30, 2010 7:56:04 PM]

Share this post


Link to post
Share on other sites
I'll have to check it out when I'm not at work (Sends email reminder), but I'd really like to see screenshots or a video of your game. I don't want to speak for everyone, but Videos and screenshots really bump up interest.

Also, I like Mendes' setup more because it makes my dated hardware feel less lonely.

Share this post


Link to post
Share on other sites
Screenshots and video were on my todo list but i still forgot :P Will get on this asap.

Haha, that reminds me, i'm not sure if this game will work on SM2.0 graphics cards. I've programmed for it but i haven't tested it on those cards.

Share this post


Link to post
Share on other sites
I wanted to try it out but it loads 10% and then crashes. error_log.xml shows this:

<Logger>
<First>Entered Program at: 30/8/2010 - 21:17:32</First>
<CNavMeshCreator>Could not find nav_mesh.xml</CNavMeshCreator>
<CSackBoyDataFromXML>Could not parse the PitchOffset string value.</CSackBoyDataFromXML>
</Logger>

Any ideas what could it be?

[Edited by - Eigen on August 31, 2010 4:19:04 AM]

Share this post


Link to post
Share on other sites
Quote:
Original post by Eigen
I wanted to try it out but it loads 10% and then crashes. error_log.xml shows this:

<Logger>
<First>Entered Program at: 30/8/2010 - 21:17:32</First>
<CNavMeshCreator>Could not find nav_mesh.xml</CNavMeshCreator>
<CSackBoyDataFromXML>Could not parse the PitchOffset string value.</CSackBoyDataFromXML>
</Logger>

Any ideas what could it be?


Hi Eigen, sorry about that. Does it happen every time you start the game? Could you either post a reply here or pm me your computer specifications?

I've checked to see what it could be, and it's likely to be corrupt asset or xml files. Or the worst case scenario is that it's not able to load some effect files. But that's unlikely since once you get to the 10% mark, that means that all the visual stuff has been loaded and is fine. Could you try and download it again and see what happens next time round?

I hope that will solve the crash.

Thanks!

Share this post


Link to post
Share on other sites
Yes, it happens every time. I tried downloading "just_game" as well, no difference. Also, the log.xml contains this line in few places:

<CVisual>SurfaceFormat.Bgra1010102 not supported</CVisual>

not sure what's it about.

Okay, my computer specs. It's an old system I know, but it should still be able to run it.

Windows XP, SP2
Cpu: 1.8 GHz
1.46 gb of ram
NVidia GeForce Go 6150 (supports sm 3.0, I checked)

Share this post


Link to post
Share on other sites
Works fine for me, I went straight to the game's exe file (I didn't need XNA 3.1). Runs pretty smooth on my old machine. Jumping over the fence was a bit annoying, but Collision seems smooth. Also, The water looks amazing and first person view is fun.

Share this post


Link to post
Share on other sites
Hello,

I have uploaded a new version of the game (CodeName:Elemental | Beta 0.2) that i'm working on. You can get the links to the downloads from this website: http://onderzoek.site90.net/. Again, i would greatly appreciate it if you could comment on the gameplay, suggest ways of bettering it, and if you come across any bugs then to report those too.

In the next release i hope to add the actual hidden level, which will be unlocked when all the beads have been collected. I also hope to add a working multiplayer mode.

Thanks and i hope you enjoy it!

P.S. Unfortunately you'll have to start over from the beginning, the old profiles won't work with the new game. In the next release i hope to solve that issue.

Share this post


Link to post
Share on other sites
Sign in to follow this