Jump to content
  • Advertisement
Sign in to follow this  
_Kami_

Visual Studio 2010 slowness...

This topic is 3002 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi,

My company recently upgraded from 2008 to 2010. What i've found is that the editor is horribly slow. Tabbing between files takes seconds, and just scrolling around or typing feels really unresponsive.

The solution file we are working with has 50-100 projects and thousands of source files.

Source control used is Perforce. (in 2008 we used niftyperforce, but in 2010 the srouce control integration works)

Language is c++.

What i've done to speed it up a bit is disabling intellisense and installing the visual assist plugin (which beats intellisense anyway)

It still feel very sluggish and unresponsive, and i cant really belive it should act like this. So i'm asking here, in the hopes that any of you guys have any tips or tweaks i can do to make it better.

Share this post


Link to post
Share on other sites
Advertisement
We haven't made the switch yet, but it was always very responsive on smaller projects when I was playing with it during the beta.

Just out of curiosity, what happensi f you disable perforce integration?

Share this post


Link to post
Share on other sites
Have you checked the status bar? usually when VS starts to chug for me, it is because intelesense/VAX is "refreshing" its databases. There isn't much of a way around it other than waiting it out, or disabling it.

Quote:

The solution file we are working with has 50-100 projects and thousands of source files.

Can you break that up a bit? Less files/solutions in the project means less things for the IDE to deal with. If you don't need it all loaded at once, just unload the other projects.

Share this post


Link to post
Share on other sites
hi,
same problem here its not exactly slow but feels not as fast as '08 as you said responsivness suffers. i am using a two monitor setup (none of them turned) 24"@1920x1280 and an HDTV at 720p. the switch to the wpf is probably the problem.

Share this post


Link to post
Share on other sites
I've heard it alleged that they've rewritten a lot of the UI components from C/C++ to C#/.net type ones, and they haven't really had time to do the optimisation stuff.

This is a reason why the editor doesn't support all the compatibility modes that the old one does. (no emacs! **Schniff**)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!