Jump to content
  • Advertisement
Sign in to follow this  
savail

OpenGL Problem with using GLUT

This topic is 2875 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello
I Installed and configured C::B from this tutorial, so maybe some files are too old im not sure: http://www.levelbylevel.com/blog/opengl-c-and-glut-using-codeblocks-and-mingw-updated/#more-198
When I create OpenGL project, the default program runs properly, but when I include glut.h instead of gl.h there are errors inside the library glut.h at 483 500 and 546 line, like: undefined reference to "function name"
No matter what the code the error always appears whenever I include glut.h. I noticed Library GLUT has included gl.h and glu.h so i don't know what's wrong. I would be very grateful for your help

Share this post


Link to post
Share on other sites
Advertisement
On the opengl forum someone told me to put #define GLUT_DISABLE_ATEXIT_HACK before #include <glut.h> and it helped partly. Now when I linked glut32 everything works fine. Thanks a lot for your post!

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!