Jump to content
  • Advertisement
Sign in to follow this  
GuyZ

Keyframe animation issue

This topic is 2855 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement
Quote:

(I'm giving a link to the same topic started by me, because for some reason gamedev.net doesn't show the '+' character)

A + doesn't show up in the preview, but it will show up in your final post. So just type away and everything should look ok when you post. A little strange but just a quirk that you get used to.

Share this post


Link to post
Share on other sites
And regarding your question, can you explain more thoroughly what the problem is?

"it goes from the first through the second one, but then keeps going between the second and the third."

This really doesn't make much sense to me.

Share this post


Link to post
Share on other sites
I'm gonna suggest you just break out the debugger on this one. It should be pretty easy to spot the problem if you breakpoint after the first loop is completed and it is interpolating the wrong frames.

Immediately I don't see what's wrong with the code, but you should be able to debug this one with your debugger.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!