• Advertisement
Sign in to follow this  

Installing SDL and OGRE on XCode

This topic is 2658 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have spent countless hours trying to figure out how to use these two things. I have tried countless IDE's and even using g++. Not once have I been able to successfully compile a program for either. I work on a mac, and I would prefer it be on XCode. I really need help, I'm getting really pissed. It just seems whatever I do, there are errors! Please someone post a guide, or similar to help me get through this. Then, as usual, if an error comes up, I will explain it to you, and you can help me fix it. I have experience in C++. I am using Snow Leopard (10.6), with the latest version of xcode (3.1).

Share this post


Link to post
Share on other sites
Advertisement
The latest is 3.2.4, 3.1 is for Leopard (10.5). Just install macports or fink for ogre or sdl.

Share this post


Link to post
Share on other sites
Ah, yes, I meant to say 3.2.4, but I got messed up on the version. As for Ogre and SDL, they are already installed. It is the setting up a project with them. I have tried many things, but all of them had ended in failure.

Share this post


Link to post
Share on other sites
Yes, of course. When creating an SDL project in XCode, cocoa complains with about a 1000 errors. I do not even include cocoa. The inclusions are fine, but in SDL I just cannot surpass the wall that cocoa has built for me.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement