Jump to content
  • Advertisement
Sign in to follow this  
initiationone

wxWidgets + wxAUI

This topic is 2974 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I can't get rid of two bugs, and think they all depend on the one cause.
First:
bug1
And second one:
bug2
Situation on the last screenshot is happened when I open tab (all content is created at this time).
Bug on the first screenshot depends on moon phase or something like that, because it's happened only sometimes when I drag the splitter.
I also tried setting up the min size, resize the window, but it changes nothing.
What I'm doing wrong?
Code:
wxMaterialEditorPane::wxMaterialEditorPane(wxWindow *parent, wxWindowID id)
: wxControl(parent, id)
{
mAuiManager.SetManagedWindow(this);
// properties
mPropGrid = new wxPropertyGrid(this, wxID_ANY, wxDefaultPosition, wxSize(400, 300));
mPropGrid->Append(new wxPropertyCategory(wxT("Material properties")));
// propery - url
mPropGrid->Append(new wxStringProperty(wxT("URL"), wxPG_LABEL,
wxT("mtl://may/be/implemented.mtl")));
// ................. ( filling entries of mPropGrid ) ...............
mAuiManager.AddPane(mPropGrid, wxLEFT);
// graph
mAuiManager.AddPane(new wxMaterialGraphPane(this, wxID_ANY), wxCENTER);

mAuiManager.Update();
}

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!