Sign in to follow this  

[assimp] always getting memory leaks when using materials

This topic is 2586 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am experiencing a little problem with assimp.

I am trying to load some .obj models. This basically works perfectly as long as there is no .mtl file available, as this always causes memory leaks. Even something like


const aiScene* scene = aiImportFile(_meshFile.c_str(), 0);
aiReleaseImport(scene);




already causes memory leaks when a .mtl file is available to the loaded object. I have tried pretty much everything i can think of, but cant get rid of them.

the .mtl file contains the following:


newmtl lambert2SG
illum 4
Kd 0.00 0.00 0.00
Ka 0.00 0.00 0.00
Tf 1.00 1.00 1.00
map_Kd brick.jpg
Ni 1.00




and the memory-leak is reported by this


Detected memory leaks!
Dumping objects ->
{1934} normal block at 0x06580068, 7248 bytes long.
Data: < lambert2SG > 0A 00 00 00 6C 61 6D 62 65 72 74 32 53 47 00 1B
Object dump complete.




Thanks for any help!

Share this post


Link to post
Share on other sites

This topic is 2586 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this