Sign in to follow this  

Incomplete walk cycle blending

This topic is 2545 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Does anyone know how to correct an incomplete walk cycle?
I am using skeletal animation and the cal3d library to display animations
My model has a walk cycle but it ends suddenly instead of having a correct loop animation.

Would I be somehow able to fix this with animation blending or do is it better to actually get in touch with the model artist and get him to redo it?

Share this post


Link to post
Share on other sites
The best would be to let the artist fix this.
As a temp fix you could add some keyframes to the end of the animation in code. The keyframe values would need to be the same as the first frame values.

It most likely won't look super good, but at least you wouldn't see any popping.

Share this post


Link to post
Share on other sites
Blending might indeed solve the issue, I think you should give it a shot and see if it's good enough (:

If it doesn't look good enough, then yeah, i guess you'd need to fix the source animation data.

Share this post


Link to post
Share on other sites

This topic is 2545 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this