Jump to content
  • Advertisement
Sign in to follow this  
monchito

Code::Blocks stop working

This topic is 2812 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi everyone:
I was using the compiler normally and now I got an error messages in all my projects. No matter what, even with the New>>Projects>>Console application.
Reinstalled CB without luck. What i'm missing?
Thanks.

-------------- Build: Debug in CCONSOLE1 ---------------

Compiling: main.cpp
cc1plus.exe: error: c:\program files\codeblocks\mingw\bin\../lib/gcc/mingw32/4.4.1/include/c++: Invalid argument
cc1plus.exe: error: c:\program files\codeblocks\mingw\bin\../lib/gcc/mingw32/4.4.1/include/c++/mingw32: Invalid argument
cc1plus.exe: error: c:\program files\codeblocks\mingw\bin\../lib/gcc/mingw32/4.4.1/include/c++/backward: Invalid argument
cc1plus.exe: error: c:\program files\codeblocks\mingw\bin\../lib/gcc/mingw32/4.4.1/../../../../include: Invalid argument
cc1plus.exe: error: c:\program files\codeblocks\mingw\bin\../lib/gcc/mingw32/4.4.1/include: Invalid argument
cc1plus.exe: error: c:\program files\codeblocks\mingw\bin\../lib/gcc/mingw32/4.4.1/include-fixed: Invalid argument
cc1plus.exe: error: c:/program files/codeblocks/mingw/lib/gcc/../../lib/gcc/mingw32/4.4.1/include/c++: Invalid argument
cc1plus.exe: error: c:/program files/codeblocks/mingw/lib/gcc/../../lib/gcc/mingw32/4.4.1/include/c++/mingw32: Invalid argument
cc1plus.exe: error: c:/program files/codeblocks/mingw/lib/gcc/../../lib/gcc/mingw32/4.4.1/include/c++/backward: Invalid argument
cc1plus.exe: error: c:/program files/codeblocks/mingw/lib/gcc/../../include: Invalid argument
cc1plus.exe: error: c:/program files/codeblocks/mingw/lib/gcc/../../lib/gcc/mingw32/4.4.1/include: Invalid argument
cc1plus.exe: error: c:/program files/codeblocks/mingw/lib/gcc/../../lib/gcc/mingw32/4.4.1/include-fixed: Invalid argument
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings


Share this post


Link to post
Share on other sites
Advertisement
The paths look a bit wired. Can you try to clean them up? You find them under Settings->Compiler&Debugger->Toolchain executables->Conmpiler's installation directory.

Maybe he is getting annoyed by having a space in the path. I haven't used windows for quite some time but i think you can but paths with spaces in quotes.

If all that fails, try a clean install of mingw under c:\mingw.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!