Jump to content
  • Advertisement
Sign in to follow this  
Anddos

Problem exporting textures with .x

This topic is 2890 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Basically i have paid someone to model me something for my fishing game i am slowly working on , so he has modeled it in 3dsmax 2009 and then saved it as an .fbx file and sent it to me , i then load my 3dsmax 9 and press import and choose the .fbx file , i then go to export and choose .x and leave the settings the same , i then double click on the .x file and the dx viewer opens with no textures on the model , it shows the textures in my 3dsmax 9, has anyone experienced anything like this and is there a solution ?

This is a picture of what i mean
http://img209.imageshack.us/img209/7787/fman.jpg

Share this post


Link to post
Share on other sites
Advertisement
It depends on your exporter and i have some questions:
In your export options, did you export texture coordinate data in your x file?
Did you save it as text file? If so open it with text editor and do search for you texture (like texture.dds) to see if it has assigned it.
Does dx viewer outputs some errors/warnings?
What is your exporter? I highly recommend to use panda exporter!

Share this post


Link to post
Share on other sites

n your export options, did you export texture coordinate data in your x file?
Did you save it as text file? If so open it with text editor and do search for you texture (like texture.dds) to see if it has assigned it.
[/quote]

not sure what you mean,the texture file is called Fisher1Dif.bmp,here is a picture of the exported options

http://img529.imageshack.us/img529/74/export.jpg

Share this post


Link to post
Share on other sites

not sure what you mean,the texture file is called Fisher1Dif.bmp,here is a picture of the exported options

http://img529.images...9/74/export.jpg

I'm not a 3dsmax person, but the export options show "Use full pathname" which implies the x-file will contain full pathnames for the textures in the materials list. The meshviewer will look where the x-file says the textures are located.

If you exported the x-file in text format, open it in an ASCII editor (such as notepad) and check to see how the textures are specified. Commonly, textures are specified without a path, and the meshviewer will look in the same directory as the x-file to file the textures.

Share this post


Link to post
Share on other sites

I'm not a 3dsmax person, but the export options show "Use full pathname" which implies the x-file will contain full pathnames for the textures in the materials list. The meshviewer will look where the x-file says the textures are located.

If you exported the x-file in text format, open it in an ASCII editor (such as notepad) and check to see how the textures are specified. Commonly, textures are specified without a path, and the meshviewer will look in the same directory as the x-file to file the textures.


yeh ive saved it as text format in the export options then opened it in notepad and searched for Fisher1Dif.bmp, but it's not finding it, so something is going wrong,ive also unticked use full path name.

Share this post


Link to post
Share on other sites
belfegor you man are a star , those setting's worked, it's only a static model atm as i am just testing the textures , the end result will have animation's :)

Share this post


Link to post
Share on other sites
I am now stuck getting animations to work , he has added a reeling animation that plays from 0 - 30 in 3dsmax , here is the exporter setting's , when i run the .x in dx viewer , the animation dosent seem to play , he says it's using frames..

here's the video of the animation in 3dsmax

http://www.youtube.c...h?v=0lkRlWuzxFw

below is the exporter setting

reelingin.jpg

xfilesetting.jpg

Share this post


Link to post
Share on other sites
Update

ive got the animation to play in dx viewer but the man dosent move like in the video above, he is using bipped to be rigged so could that be a problem with .x files?

Share this post


Link to post
Share on other sites
Its been really long time since when i last played with exporting animated characters this way so i forgot correct options but i'll try to help you. I know from my experience that animating using bipeds is fine and does work when exported. So if he is doing everything right on his end you could try to tick "Bones" checkbox on "3ds max objects" tab and (under sam tab) make sure that "dummy" cb is unchecked and for the rest leave it as on your last screenshot.
Can you get video from dx viewer to be able to see a problem? Possibly longer then 1s (try looping for 10-15s).

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!