Jump to content
  • Advertisement
Sign in to follow this  
Backfist

EffectPools constant buffer crashes after releasing one of child effect

This topic is 2803 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello,
As in the topic. I v got an Effect Pool and few child effects. When I release any of child effect dx dll crashes with:
Access violation reading location 0x00000000. error.
If none of child effects is released, effect pools works properly.


// Set the constant buffer

ID3D10EffectConstantBuffer* cbuffer = m_effectPool->AsEffect()->GetConstantBufferByName("clipPlaneData");
if(cbuffer != NULL && cbuffer->IsValid() && m_useCounter != 0) {
cbuffer->SetConstantBuffer(m_clipPlaneDataBuffer);//HERE IT CRASHES
}

PIX debug log

Frame 000001 ........PRE: <this=0x0422a008>ID3D10Buffer::Map(D3D10_MAP_WRITE_DISCARD, 0, 0x001DE440)
Frame 000001 ........POST: <S_OK><this=0x0422a008> ID3D10Buffer::Map(D3D10_MAP_WRITE_DISCARD, 0, 0x001DE440)
Frame 000001 ........PRE: <this=0x0422a008>ID3D10Buffer::Unmap()
Frame 000001 ........POST: <><this=0x0422a008> ID3D10Buffer::Unmap()
An unhandled exception occurred.


There is no crash when using ID3D10EffectVariable* interface.
Does anyone have any idea what can couse this problem ?

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!